Autenticación en Flutter

¿Qué hay en el Gradle?

Puede encontrar el siguiente error si luego prueba la biblioteca de clases. Parece que hay un requisito mínimo de versión, y deberá ir al directorio “wrapper” y actualizar su archivo gradle-wrapper.properties. Por ejemplo, cambie la entrada del archivo, gradle-4.4-all.zip a gradle-5.1.1-all.zip.

El siguiente error que puede encontrar implica un archivo json. A continuación se muestra un ejemplo del error, y se queja de que falta el archivo json. Deberá ir a Firebase (teniendo en cuenta el nombre del paquete de su aplicación de muestra) y crear un archivo de configuración google-services.json: sus proyectos de Firebase

SHA1

Junto con ese archivo de configuración, es probable que necesite obtener el número SHA1 para su aplicación. Visite este sitio web para obtener exactamente eso, autenticar a su cliente. Y así, después de todo eso. Estás listo para ejecutar la aplicación de muestra e iniciar sesión en Firebase.

A partir de la versión 4.0, puede usar Facebook para autenticarse. Sin embargo, eso significa que debe obtener una “identificación de la aplicación de Facebook”. Si no lo hace, perderá la conexión a su dispositivo con un “asegúrese de llamar a FacebookSdk.sdkInitialize () primero”.

Deberá actualizar sus archivos de Android, tanto AndroidManifest.xml como strings.xml. Además de ir al sitio web “Facebook para desarrolladores” y crear una nueva aplicación para obtener la identificación adecuada.